Multiple Sites

Incident Report for DGtek Network

Resolved

A UPS fault caused devices at the site to go offline, impacting services. Our technicians have attended the site and rectified the issue. All affected services are now restored.
Posted Apr 24, 2026 - 17:05 AEST

Investigating

Engineers have observed network alarms which are currently causing disruption to services for some customers across multiple sites. Engineers are now investigating the issue. Further updates will be given as soon as they are available.

Sites Affected:

150 Kerr Street
353 Napier Street
300 Young Street , Fitzroy

We apologise for any inconvenience caused and are working to resolve issue as soon as possible.
Posted Apr 24, 2026 - 15:02 AEST