22-24 Jane Bell Lane Melbourne
Incident Report for DGtek Network
Resolved
This incident has been resolved.
Posted Apr 09, 2024 - 13:32 AEST
Identified
Engineers have observed network alarms at the listed site which are causing disruption to some customer services. Engineers are now investigating the issue. Further updates will be given as soon as they are available.

Contractors are working at site which has brought down or equipment. Current ETA for their work to be complete is 30-40 minutes.
Posted Apr 09, 2024 - 12:25 AEST