88 Beaconsfield Parade Albert Park
Incident Report for DGtek Network
Resolved
This incident has been resolved.
Posted Apr 10, 2024 - 09:22 AEST
Investigating
Engineers have observed network alarms at the listed site which are causing disruption to some customer services. Engineers are now investigating the issue. Further updates will be given as soon as they are available.

We apologise for any inconvenience caused and are working to resolve issue as soon as possible.
Posted Apr 10, 2024 - 09:16 AEST