7 Yarra Street, Geelong
Incident Report for DGtek Network
Resolved
Power had been intentionally disconnected from DGtek equipment. Power has been reconnected, and services restored.
Posted Jan 12, 2025 - 12:02 AEDT
Update
The Building Manager has advised that the power issue has been resolved, however DGtek network equipment remains offline. A DGtek field engineer has been dispatched to investigate further.
Posted Jan 12, 2025 - 10:46 AEDT
Identified
The Building Manager has advised there is flooding from Level 17 and, and power has been shut down in the risers. DGtek has been informed that this will take couple of hours to fix and they are working with the electrical company to rectify the issue.
Posted Jan 11, 2025 - 12:38 AEDT
Investigating
Engineers have observed network alarms at the listed site which are causing disruption to some customer services. Engineers are now investigating the issue. Further updates will be given as soon as they are available.

We apologise for any inconvenience caused and are working to resolve issue as soon as possible.
Posted Jan 11, 2025 - 12:26 AEDT