470 Collins Street, Melbourne

Incident Report for DGtek Network

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 09:09 AEDT

Monitoring

The device has been recovered and stable for over 3 hours. We are monitoring the status Until Tomorrow.
Posted Nov 18, 2025 - 00:00 AEDT

Update

The building manager has organized an electrician to check the power issue at Level 10 Tomorrow (18th).
Posted Nov 17, 2025 - 14:47 AEDT

Identified

DGtek Technician has identified a power issue on Level 10 that caused the device to go offline. Further updates will be given as soon as they are available.
Posted Nov 17, 2025 - 14:18 AEDT

Update

A field Technician has been dispatched to the site for further investigation. Further updates will be provided as they become available.
Posted Nov 17, 2025 - 13:49 AEDT

Investigating

Engineers have observed network alarms at the listed site which are causing disruption to some customer services. Engineers are now investigating the issue. Further updates will be given as soon as they are available.

We apologise for any inconvenience caused and are working to resolve issue as soon as possible.
Posted Nov 17, 2025 - 13:46 AEDT