70 Carl Street Woolloongabba - Palazzo Apartments
Incident Report for DGtek Network
Resolved
This incident has been resolved.
Posted Mar 22, 2024 - 11:26 AEDT
Investigating
Engineers have observed network alarms at the listed site which are causing disruption to some customer services. Engineers are now investigating the issue. Further updates will be given as soon as they are available.

We apologise for any inconvenience caused and are working to resolve issue as soon as possible.
Posted Mar 22, 2024 - 09:59 AEDT