44 Merton St, Albert Park

Incident Report for DGtek Network

Resolved

The Fiber Team has completed the necessary repairs, and the service has been successfully restored following the fix
Posted Nov 13, 2025 - 13:43 AEDT

Identified

outage had been occurred during a fiber audit. Fiber team is already dispatched to attend to the issue
Posted Nov 13, 2025 - 12:08 AEDT